Instalando OpenSSL para o Ruby no Ubuntu


Leia em menos de um minuto

Se você precisar usar alguma gem que necessita do suporte a OpenSSL, no Ubuntu, você irá receber o seguinte erro:

irb(main):001:0> require 'openssl'
LoadError: no such file to load -- openssl
        from (irb):1:in `require'
        from (irb):1

Para corrigir isto, basta executar o seguinte comando: sudo aptitude install libopenssl-ruby libssl-dev libssl0.9.8. Ele irá instalar alguns pacotes e você não receberá mais nenhum erro.