Usando PHP5 na RailsPlayground


Leia em menos de um minuto

O RailsPlayground vem por padrão com PHP 4.4.4, mas é possível utilizar o PHP5.

Para utilizar o PHP5, crie um arquivo ".htaccess" e coloque a seguinte configuração:

AddHandler application/x-httpd-php5 .php

Caso você precise do PHP4 para uma aplicação mais antiga, você pode utilizar a configuração abaixo.

AddHandler application/x-httpd-php .php

O Apache aceita arquivos ".htaccess" em cada diretório. Desta maneira, é possível alternar entre uma versão e outra sempre que você precisar. Basta criar um arquivo específico para aquele diretório com a linha corresponde à versão que você precisa.